CVEvulnerability
CVE-2025-27371
6.9 MEDIUM
Official page ↗
- Status
- Deferred
- Published
- 2025-03-03
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 6.9 MEDIUM — CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:H/A:N
- Weaknesses
- CWE-305
Description
In certain IETF OAuth 2.0-related specifications, when the JSON Web Token Profile for OAuth 2.0 Client Authentication mechanism is used, there are ambiguities in the audience values of JWTs sent to authorization servers. The affected RFCs may include RFC 7523, and also RFC 7521, RFC 7522, RFC 9101 (JAR), and RFC 9126 (PAR).
Related
Weakness · CWE (1)
- CWE-305 Authentication Bypass by Primary Weakness weakness
References
- https://eprint.iacr.org/2025/629 eprint.iacr.org
- https://github.com/OWASP/ASVS/issues/2678 github.com
- https://openid.net/notice-of-a-security-vulnerability/ openid.net
- https://openid.net/wp-content/uploads/2025/01/OIDF-Responsible-Disclosure-Notice-on-Security-Vulnerability-for-private_key_jwt.pdf openid.net
- https://talks.secworkshop.events/osw2025/talk/R8D9BS/ talks.secworkshop.events