CVEvulnerability
CVE-2025-27423
7.1 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2025-03-03
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.1 HIGH — CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N
- Weaknesses
- CWE-77
Description
Vim is an open source, command line text editor. Vim is distributed with the tar.vim plugin, that allows easy editing and viewing of (compressed or uncompressed) tar files. Starting with 9.1.0858, the tar.vim plugin uses the ":read" ex command line to append below the cursor position, however the is not sanitized and is taken literally from the tar archive. This allows to execute shell commands via special crafted tar archives. Whether this really happens, depends on the shell being used ('shell' option, which is set using $SHELL). The issue has been fixed as of Vim patch v9.1.1164
Affected configurations
• vim vim (>= 9.1.0858 < 9.1.1164)
• netapp hci compute node
Related
Weakness · CWE (1)
- CWE-77 Improper Neutralization of Special Elements used in a Command weakness
References
- https://github.com/vim/vim/commit/129a8446d23cd9cb4445fcfea259cba5e0487d29 Patch
- https://github.com/vim/vim/commit/334a13bff78aa0ad206bc436885f63e3a0bab399 Patch
- https://github.com/vim/vim/security/advisories/GHSA-wfmf-8626-q3r3 Vendor Advisory
- https://security.netapp.com/advisory/ntap-20250502-0002/ Third Party Advisory