CVEvulnerability
CVE-2025-27446
7.8 HIGH
Official page ↗
- Status
- Modified
- Published
- 2025-07-06
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 7.8 HIGH — CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-732
Description
Incorrect Permission Assignment for Critical Resource vulnerability in Apache APISIX(java-plugin-runner).
Local listening file permissions in APISIX plugin runner allow a local attacker to elevate privileges.
This issue affects Apache APISIX(java-plugin-runner): from 0.2.0 through 0.5.0.
Users are recommended to upgrade to version 0.6.0 or higher, which fixes the issue.
Affected configurations
• apache apisix (>= 0.2 <= 0.5)
Related
Weakness · CWE (1)
- CWE-732 Incorrect Permission Assignment for Critical Resource weakness
References
- https://lists.apache.org/thread/qwxnxolt0j5nvjfpr0mlz6h7nrtvyzng Mailing List, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2025/07/06/1 www.openwall.com
- http://www.openwall.com/lists/oss-security/2025/07/07/1 www.openwall.com