CVEvulnerability
CVE-2025-27505
5.3 MEDIUM
Official page ↗
- Status
- Analyzed
- Published
- 2025-06-10
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 5.3 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- Weaknesses
- CWE-862
Description
GeoServer is an open source server that allows users to share and edit geospatial data. It is possible to bypass the default REST API security and access the index page. The REST API security handles rest and its subpaths but not rest with an extension (e.g., rest.html). The REST API index can disclose whether certain extensions are installed. This vulnerability is fixed in 2.26.3 and 2.25.6. As a workaround, in ${GEOSERVER_DATA_DIR}/security/config.xml, change the paths for the rest filter to /rest.*,/rest/** and change the paths for the gwc filter to /gwc/rest.*,/gwc/rest/** and restart GeoServer.
Affected configurations
• osgeo geoserver (< 2.25.6)
• osgeo geoserver (>= 2.26.0 < 2.26.3)
Related
Weakness · CWE (1)
- CWE-862 Missing Authorization weakness
References
- https://github.com/geoserver/geoserver/pull/8170 Patch
- https://github.com/geoserver/geoserver/security/advisories/GHSA-h86g-x8mm-78m5 Third Party Advisory
- https://osgeo-org.atlassian.net/browse/GEOS-11664 Issue Tracking, Patch
- https://osgeo-org.atlassian.net/browse/GEOS-11776 Permissions Required