CVEvulnerability
CVE-2025-27598
7.5 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2025-03-06
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CVSS 3.1 ([email protected])
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-787
Description
ImageSharp is a 2D graphics API. An Out-of-bounds Write vulnerability has been found in the ImageSharp gif decoder, allowing attackers to cause a crash using a specially crafted gif. This can potentially lead to denial of service. The problem has been patched. All users are advised to upgrade to v3.1.7 or v2.1.10.
Affected configurations
• sixlabors imagesharp (< 2.1.10)
• sixlabors imagesharp (>= 3.0.0 < 3.1.7)
Related
Weakness · CWE (1)
- CWE-787 Out-of-bounds Write weakness
References
- https://github.com/SixLabors/ImageSharp/issues/2859 Exploit, Issue Tracking
- https://github.com/SixLabors/ImageSharp/pull/2890 Issue Tracking, Patch
- https://github.com/SixLabors/ImageSharp/security/advisories/GHSA-2cmq-823j-5qj8 Vendor Advisory
- https://github.com/SixLabors/ImageSharp/issues/2859 Exploit, Issue Tracking