CVEvulnerability
CVE-2025-27821
7.3 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2026-01-26
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 7.3 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
- Weaknesses
- CWE-787
Description
Out-of-bounds Write vulnerability in Apache Hadoop HDFS native client.
This issue affects Apache Hadoop: from 3.2.0 before 3.4.2.
Users are recommended to upgrade to version 3.4.2, which fixes the issue.
Affected configurations
• apache hadoop (>= 3.2.0 < 3.4.2)
Related
Weakness · CWE (1)
- CWE-787 Out-of-bounds Write weakness
References
- https://lists.apache.org/thread/kwjhyyx0wl2z9b0mw0styjk0hhdbyplh Mailing List, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2026/01/23/7 Mailing List, Third Party Advisory