CVEvulnerability
CVE-2025-29926
7.9 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2025-03-19
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 4.0 ([email protected])
- 7.9 HIGH — CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:L/SC:H/SI:H/SA:H/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
- CVSS 3.1 ([email protected])
- 9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-285, CWE-862
Description
XWiki Platform is a generic wiki platform. Prior to 15.10.15, 16.4.6, and 16.10.0, any user can exploit the WikiManager REST API to create a new wiki, where the user could become an administrator and so performs other attacks on the farm. Note that this REST API is not bundled in XWiki Standard by default: it needs to be installed manually through the extension manager. The problem has been patched in versions 15.10.15, 16.4.6 and 16.10.0 of the REST module.
Affected configurations
• xwiki xwiki (>= 5.4.1 < 15.10.15)
• xwiki xwiki (>= 16.0.0 < 16.4.6)
• xwiki xwiki (>= 16.5.0 < 16.10.0)
• xwiki xwiki 5.4
Related
References
- https://github.com/xwiki/xwiki-platform/commit/82aa670106c7f5e6238ca6ed59a52d1800e05b99 Patch
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-gfp2-6qhm-7x43 Vendor Advisory
- https://jira.xwiki.org/browse/XWIKI-22490 Exploit, Issue Tracking, Vendor Advisory