CVEvulnerability

CVE-2025-29927

9.1 CRITICAL Published 2025-03-21 Modified 2026-06-17 Official page ↗
Status
Analyzed
Published
2025-03-21
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
9.1 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Weaknesses
CWE-285, CWE-863

Description

Next.js is a React framework for building full-stack web applications. Starting in version 1.11.4 and prior to versions 12.3.5, 13.5.9, 14.2.25, and 15.2.3, it is possible to bypass authorization checks within a Next.js application, if the authorization check occurs in middleware. If patching to a safe version is infeasible, it is recommend that you prevent external user requests which contain the x-middleware-subrequest header from reaching your Next.js application. This vulnerability is fixed in 12.3.5, 13.5.9, 14.2.25, and 15.2.3.

Affected configurations

• vercel next.js (>= 11.1.4 < 12.3.5) • vercel next.js (>= 13.0.0 < 13.5.9) • vercel next.js (>= 14.0.0 < 14.2.25) • vercel next.js (>= 15.0.0 < 15.2.3)

Related

Weakness · CWE (2)

  • CWE-285 Improper Authorization weakness
  • CWE-863 Incorrect Authorization weakness

References