CVEvulnerability
CVE-2025-30067
7.2 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2025-03-27
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 7.2 HIGH — CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-94
Description
Improper Control of Generation of Code ('Code Injection') vulnerability in Apache Kylin.
If an attacker gets access to Kylin's system or project admin permission, the JDBC connection configuration maybe altered to execute arbitrary code from the remote. You are fine as long as the Kylin's system and project admin access is well protected.
This issue affects Apache Kylin: from 4.0.0 through 5.0.1.
Users are recommended to upgrade to version 5.0.2 or above, which fixes the issue.
Affected configurations
• apache kylin (>= 4.0.0 < 5.0.2)
Related
Weakness · CWE (1)
- CWE-94 Improper Control of Generation of Code weakness
References
- https://lists.apache.org/thread/6j19pt8yoqfphf1lprtrzoqkvz1gwbnc Mailing List, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2025/03/27/4 Mailing List, Third Party Advisory