CVEvulnerability
CVE-2025-30145
7.5 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2025-06-10
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-835
Description
GeoServer is an open source server that allows users to share and edit geospatial data. Malicious Jiffle scripts can be executed by GeoServer, either as a rendering transformation in WMS dynamic styles or as a WPS process, that can enter an infinite loop to trigger denial of service. This vulnerability is fixed in 2.27.0, 2.26.3, and 2.25.7. This vulnerability can be mitigated by disabling WMS dynamic styling and the Jiffle process.
Affected configurations
• osgeo geoserver (< 2.25.7)
• osgeo geoserver (>= 2.26.0 < 2.26.3)
Related
Weakness · CWE (1)
- CWE-835 Loop with Unreachable Exit Condition weakness
References
- https://github.com/geoserver/geoserver/security/advisories/GHSA-gr67-pwcv-76gf Third Party Advisory
- https://github.com/geosolutions-it/jai-ext/pull/307 Patch
- https://osgeo-org.atlassian.net/browse/GEOS-11778 Permissions Required