CVEvulnerability
CVE-2025-30162
4.3 MEDIUM
Official page ↗
- Status
- Analyzed
- Published
- 2025-03-24
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 3.2 LOW — CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:L/I:N/A:N
- CVSS 3.1 ([email protected])
- 4.3 MEDIUM — CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:C/C:L/I:N/A:N
- Weaknesses
- CWE-863
Description
Cilium is a networking, observability, and security solution with an eBPF-based dataplane. For Cilium users who use Gateway API for Ingress for some services and use LB-IPAM or BGP for LB Service implementation and use network policies to block egress traffic from workloads in a namespace to workloads in other namespaces, egress traffic from workloads covered by such network policies to LoadBalancers configured by `Gateway` resources will incorrectly be allowed. LoadBalancer resources not deployed via a Gateway API configuration are not affected by this issue. This issue affects: Cilium v1.15 between v1.15.0 and v1.15.14 inclusive, v1.16 between v1.16.0 and v1.16.7 inclusive, and v1.17 between v1.17.0 and v1.17.1 inclusive. This issue is fixed in Cilium v1.15.15, v1.16.8, and v1.17.2. A Clusterwide Cilium Network Policy can be used to work around this issue for users who are unable to upgrade.
Affected configurations
• cilium cilium (>= 1.15.0 < 1.15.15)
• cilium cilium (>= 1.16.0 < 1.16.8)
• cilium cilium (>= 1.17.0 < 1.17.2)
Related
Weakness · CWE (1)
- CWE-863 Incorrect Authorization weakness
References
- https://docs.cilium.io/en/stable/network/lb-ipam Product
- https://github.com/cilium/cilium/security/advisories/GHSA-24qp-4xx8-3jvj Mitigation, Patch, Third Party Advisory
- https://github.com/cilium/proxy/pull/1172 Patch