CVEvulnerability
CVE-2025-30177
6.5 MEDIUM
Official page ↗
- Status
- Analyzed
- Published
- 2025-04-01
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 6.5 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
- Weaknesses
- CWE-164
Description
Bypass/Injection vulnerability in Apache Camel in Camel-Undertow component under particular conditions.
This issue affects Apache Camel: from 4.10.0 before 4.10.3, from 4.8.0 before 4.8.6.
Users are recommended to upgrade to version 4.10.3 for 4.10.x LTS and 4.8.6 for 4.8.x LTS.
Camel undertow component is vulnerable to Camel message header injection, in particular the custom header filter strategy used by the component only filter the "out" direction, while it doesn't filter the "in" direction.
This allows an attacker to include Camel specific headers that for some Camel components can alter the behaviour such as the camel-bean component, or the camel-exec component.
Affected configurations
• apache camel (>= 4.8.0 < 4.8.6)
• apache camel (>= 4.10.0 < 4.10.3)
Related
Weakness · CWE (1)
- CWE-164 Improper Neutralization of Internal Special Elements weakness
References
- https://camel.apache.org/security/CVE-2025-27636.html Not Applicable
- https://camel.apache.org/security/CVE-2025-29891.html Not Applicable
- https://lists.apache.org/thread/dj79zdgw01j337lr9gvyy4sv8xfyw8py Mailing List, Vendor Advisory