CVEvulnerability
CVE-2025-31125
CISA Known Exploited Vulnerability
Vite Vitejs Improper Access Control Vulnerability — Vite Vitejs
Vite Vitejs contains an improper access control vulnerability that exposes content of non-allowed files using ?inline&import or ?raw?import. Only apps explicitly exposing the Vite dev server to the network (using --host or server.host config option) are affected.
- Added to KEV
- 2026-01-22
- Remediation due
- 2026-02-12
- Ransomware use
- Unknown
- Required action
- Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.
- Notes
- This vulnerability could affect an open-source component, third-party library, protocol, or proprietary implementation that could be used by different products. For more information, please see: https://github.com/vitejs/vite/commit/59673137c45ac2bcfad1170d954347c1a17ab949 ; https://nvd.nist.gov/vuln/detail/CVE-2025-31125
- Status
- Analyzed
- Published
- 2025-03-31
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 5.3 MEDIUM — CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:N/A:N
- CVSS 3.1 ([email protected])
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- Weaknesses
- CWE-200, CWE-284
Description
Vite is a frontend tooling framework for javascript. Vite exposes content of non-allowed files using ?inline&import or ?raw?import. Only apps explicitly exposing the Vite dev server to the network (using --host or server.host config option) are affected. This vulnerability is fixed in 6.2.4, 6.1.3, 6.0.13, 5.4.16, and 4.5.11.
Affected configurations
• vitejs vite (< 4.5.11)
• vitejs vite (>= 5.0.0 < 5.4.16)
• vitejs vite (>= 6.0.0 < 6.0.13)
• vitejs vite (>= 6.1.0 < 6.1.3)
• vitejs vite (>= 6.2.0 < 6.2.4)
Related
References
- https://github.com/vitejs/vite/commit/59673137c45ac2bcfad1170d954347c1a17ab949 Patch
- https://github.com/vitejs/vite/security/advisories/GHSA-4r4m-qw57-chr8 Exploit, Vendor Advisory
- https://github.com/vitejs/vite/security/advisories/GHSA-4r4m-qw57-chr8 Exploit, Vendor Advisory
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2025-31125 US Government Resource