CVEvulnerability
CVE-2025-31650
7.5 HIGH
Official page ↗
- Status
- Modified
- Published
- 2025-04-28
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-459
Description
Improper Input Validation vulnerability in Apache Tomcat. Incorrect error handling for some invalid HTTP priority headers resulted in incomplete clean-up of the failed request which created a memory leak. A large number of such requests could trigger an OutOfMemoryException resulting in a denial of service.
This issue affects Apache Tomcat: from 9.0.76 through 9.0.102, from 10.1.10 through 10.1.39, from 11.0.0-M2 through 11.0.5.
The following versions were EOL at the time the CVE was created but are
known to be affected: 8.5.90 though 8.5.100.
Users are recommended to upgrade to version 9.0.104, 10.1.40 or 11.0.6 which fix the issue.
Affected configurations
• apache tomcat (>= 9.0.76 < 9.0.104)
• apache tomcat (>= 10.1.10 < 10.1.40)
• apache tomcat (>= 11.0.1 < 11.0.6)
• apache tomcat 11.0.0
Related
Weakness · CWE (1)
- CWE-459 Incomplete Cleanup weakness
References
- https://lists.apache.org/thread/j6zzk0y3yym9pzfzkq5vcyxzz0yzh826 Mailing List, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2025/04/28/2 Mailing List, Third Party Advisory
- https://lists.debian.org/debian-lts-announce/2025/07/msg00009.html lists.debian.org