CVEvulnerability
CVE-2025-31698
7.5 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2025-06-19
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- Weaknesses
- CWE-284
Description
ACL configured in ip_allow.config or remap.config does not use IP addresses that are provided by PROXY protocol.
Users can use a new setting (proxy.config.acl.subjects) to choose which IP addresses to use for the ACL if Apache Traffic Server is configured to accept PROXY protocol.
This issue affects undefined: from 10.0.0 through 10.0.6, from 9.0.0 through 9.2.10.
Users are recommended to upgrade to version 9.2.11 or 10.0.6, which fixes the issue.
Affected configurations
• apache traffic server (>= 9.0.0 < 9.2.11)
• apache traffic server (>= 10.0.0 < 10.0.6)
Related
Weakness · CWE (1)
- CWE-284 Improper Access Control weakness
References
- https://lists.apache.org/thread/15t32nxbypqg1m2smp640vjx89o6v5f8 Mailing List, Vendor Advisory