CVEvulnerability

CVE-2025-32432

10.0 CRITICAL Known exploited Published 2025-04-25 Modified 2026-09-24 Official page ↗

CISA Known Exploited Vulnerability

Craft CMS Code Injection Vulnerability — Craft CMS Craft CMS

Craft CMS contains a code injection vulnerability that allows a remote attacker to execute arbitrary code.

Added to KEV
2026-03-20
Remediation due
2026-04-03
Ransomware use
Unknown
Required action
Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.
Notes
https://craftcms.com/knowledge-base/craft-cms-cve-2025-32432 ; https://github.com/craftcms/cms/security/advisories/GHSA-f3gw-9ww9-jmc3 ; https://nvd.nist.gov/vuln/detail/CVE-2025-32432
Status
Analyzed
Published
2025-04-25
Last modified
2026-09-24
Assigner
[email protected]
CVSS 3.1 ([email protected])
10.0 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:L
CVSS 3.1 ([email protected])
10.0 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
Weaknesses
CWE-94

Description

Craft is a flexible, user-friendly CMS for creating custom digital experiences on the web and beyond. Starting from version 3.0.0-RC1 to before 3.9.15, 4.0.0-RC1 to before 4.14.15, and 5.0.0-RC1 to before 5.6.17, Craft is vulnerable to remote code execution. This is a high-impact, low-complexity attack vector. This issue has been patched in versions 3.9.15, 4.14.15, and 5.6.17, and is an additional fix for CVE-2023-41892.

Affected configurations

• craftcms craft cms (>= 3.0.0 < 3.9.15) • craftcms craft cms (>= 4.0.0 < 4.14.15) • craftcms craft cms (>= 5.0.0 < 5.6.17)

Related

Weakness · CWE (1)

  • CWE-94 Improper Control of Generation of Code weakness

References