CVEvulnerability
CVE-2025-32442
7.5 HIGH
Official page ↗
- Status
- Modified
- Published
- 2025-04-18
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- Weaknesses
- CWE-1287
Description
Fastify is a fast and low overhead web framework, for Node.js. In versions 5.0.0 to 5.3.0 as well as version 4.29.0, applications that specify different validation strategies for different content types have a possibility to bypass validation by providing a _slightly altered_ content type such as with different casing or altered whitespacing before `;`. This was patched in v5.3.1, but the initial patch did not cover all problems. This has been fully patched in v5.3.2 and v4.29.1. A workaround involves not specifying individual content types in the schema.
Affected configurations
• fastify fastify (>= 5.0.0 < 5.3.2)
• fastify fastify 4.29.0
Related
Weakness · CWE (1)
- CWE-1287 Improper Validation of Specified Type of Input weakness
References
- https://github.com/fastify/fastify/commit/436da4c06dfbbb8c24adee3a64de0c51e4f47418 Patch
- https://github.com/fastify/fastify/commit/f3d2bcb3963cd570a582e5d39aab01a9ae692fe4 Patch
- https://github.com/fastify/fastify/security/advisories/GHSA-mg2h-6x62-wpwc Exploit, Third Party Advisory
- https://hackerone.com/reports/3087928 Permissions Required