CVEvulnerability

CVE-2025-32972

5.3 MEDIUM Published 2025-04-30 Modified 2026-06-17 Official page ↗
Status
Analyzed
Published
2025-04-30
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
2.7 LOW — CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:L
CVSS 3.1 ([email protected])
5.3 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Weaknesses
CWE-285

Description

XWiki is a generic wiki platform. In versions starting from 6.1-milestone-1 to before 15.10.12, from 16.0.0-rc-1 to before 16.4.3, and from 16.5.0-rc-1 to before 16.8.0-rc-1, the script API of the LESS compiler in XWiki is incorrectly checking for rights when calling the cache cleaning API, making it possible to clean the cache without having programming right. The only impact of this is a slowdown in XWiki execution as the caches are re-filled. As this vulnerability requires script right to exploit, and script right already allows unlimited execution of scripts, the additional impact due to this vulnerability is low. This issue has been patched in versions 15.10.12, 16.4.3, and 16.8.0-rc-1.

Affected configurations

• xwiki xwiki (>= 6.2 < 15.10.12) • xwiki xwiki (>= 16.0.0 < 16.4.3) • xwiki xwiki (>= 16.5.0 < 16.8.0) • xwiki xwiki 6.1

Related

Weakness · CWE (1)

  • CWE-285 Improper Authorization weakness

References