CVEvulnerability
CVE-2025-32974
9.0 CRITICAL
Official page ↗
- Status
- Analyzed
- Published
- 2025-04-30
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 9.0 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H
- CVSS 3.1 ([email protected])
- 9.0 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H
- Weaknesses
- CWE-116, CWE-269
Description
XWiki is a generic wiki platform. In versions starting from 15.9-rc-1 to before 15.10.8 and from 16.0.0-rc-1 to before 16.2.0, the required rights analysis doesn't consider TextAreas with default content type. When editing a page, XWiki warns since version 15.9 when there is content on the page like a script macro that would gain more rights due to the editing. This analysis doesn't consider certain kinds of properties, allowing a user to put malicious scripts in there that will be executed after a user with script, admin, or programming rights edited the page. Such a malicious script could impact the confidentiality, integrity and availability of the whole XWiki installation. This issue has been patched in versions 15.10.8 and 16.2.0.
Affected configurations
• xwiki xwiki (>= 15.9 < 15.10.8)
• xwiki xwiki (>= 16.0.0 < 16.2.0)
Related
References
- https://github.com/xwiki/xwiki-platform/commit/153dbfa2ef1a7a0a644fe3f889684c6a8738c5fc Patch
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-mvgm-3rw2-7j4r Patch, Vendor Advisory
- https://jira.xwiki.org/browse/XWIKI-22002 Issue Tracking, Vendor Advisory
- https://jira.xwiki.org/browse/XWIKI-22002 Issue Tracking, Vendor Advisory