CVEvulnerability
CVE-2025-3438
7.3 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2025-05-02
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 6.5 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
- CVSS 3.1 ([email protected])
- 7.3 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
- Weaknesses
- CWE-269
Description
The MStore API – Create Native Android & iOS Apps On The Cloud plugin for WordPress is vulnerable to limited privilege escalation in all versions up to, and including, 4.17.4. This is due to a lack of restriction of role when registering. This makes it possible for unauthenticated attackers to to register with the 'wcfm_vendor' role, which is a Store Vendor role in the WCFM Marketplace – Multivendor Marketplace for WooCommerce plugin for WordPress. The vulnerability can only be exploited if the WCFM Marketplace – Multivendor Marketplace for WooCommerce plugin is installed and activated. The vulnerability was partially patched in version 4.17.3.
Affected configurations
• inspireui mstore api (< 4.17.5)
Related
Weakness · CWE (1)
- CWE-269 Improper Privilege Management weakness
References
- https://plugins.trac.wordpress.org/browser/mstore-api/trunk/controllers/flutter-user.php#L392 Product
- https://plugins.trac.wordpress.org/browser/mstore-api/trunk/controllers/flutter-user.php#L413 Product
- https://plugins.trac.wordpress.org/changeset/3277790 Patch
- https://plugins.trac.wordpress.org/changeset/3279132/ Patch
- https://www.wordfence.com/threat-intel/vulnerabilities/id/be5d86ad-f94b-4fcb-9b74-ecddde2bf29d?source=cve Third Party Advisory