CVEvulnerability
CVE-2025-4215
2.3 LOW
Official page ↗
- Status
- Analyzed
- Published
- 2025-05-02
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 4.0 ([email protected])
- 2.3 LOW — CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
- CVSS 3.1 ([email protected])
- 3.1 LOW — CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:N/A:L
- CVSS 3.1 ([email protected])
- 3.7 LOW — CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L
- CVSS 2.0 ([email protected])
- 2.6 LOW — AV:N/AC:H/Au:N/C:N/I:N/A:P
- Weaknesses
- CWE-1333, CWE-400
Description
A vulnerability was found in gorhill uBlock Origin up to 1.63.3b16. It has been classified as problematic. Affected is the function currentStateChanged of the file src/js/1p-filters.js of the component UI. The manipulation leads to inefficient regular expression complexity. It is possible to launch the attack remotely. The complexity of an attack is rather high. The exploitability is told to be difficult. The exploit has been disclosed to the public and may be used. Upgrading to version 1.63.3b17 is able to address this issue. The patch is identified as eaedaf5b10d2f7857c6b77fbf7d4a80681d4d46c. It is recommended to upgrade the affected component.
Affected configurations
• ublockorigin ublock origin (< 1.63.3)
• ublockorigin ublock origin 1.63.3
• debian debian linux 11.0
Related
References
- https://github.com/gorhill/uBlock/commit/eaedaf5b10d2f7857c6b77fbf7d4a80681d4d46c Exploit, Patch
- https://github.com/gorhill/uBlock/releases/tag/1.63.3b17 Release Notes
- https://vuldb.com/?ctiid.307194 Permissions Required, VDB Entry
- https://vuldb.com/?id.307194 Third Party Advisory, VDB Entry
- https://vuldb.com/?submit.562301 Third Party Advisory, VDB Entry
- https://lists.debian.org/debian-lts-announce/2025/06/msg00013.html Mailing List
- https://github.com/gorhill/uBlock/commit/eaedaf5b10d2f7857c6b77fbf7d4a80681d4d46c Exploit, Patch