CVEvulnerability
CVE-2025-46647
5.3 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2025-07-02
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 5.3 MEDIUM — CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N
- Weaknesses
- CWE-302
Description
A vulnerability of plugin openid-connect in Apache APISIX.
This vulnerability will only have an impact if all of the following conditions are met:
1. Use the openid-connect plugin with introspection mode
2. The auth service connected to openid-connect provides services to multiple issuers
3. Multiple issuers share the same private key and relies only on the issuer being different
If affected by this vulnerability, it would allow an attacker with a valid account on one of the issuers to log into the other issuer.
This issue affects Apache APISIX: until 3.12.0.
Users are recommended to upgrade to version 3.12.0 or higher.
Affected configurations
• apache apisix (< 3.12.0)
Related
Weakness · CWE (1)
- CWE-302 Authentication Bypass by Assumed-Immutable Data weakness
References
- https://lists.apache.org/thread/yrpp2cd3o4qkxlrh421mq8gsrt0k4x0w Mailing List, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2025/07/02/1 www.openwall.com