CVEvulnerability
CVE-2025-46701
7.3 HIGH
Official page ↗
- Status
- Modified
- Published
- 2025-05-29
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 7.3 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
- Weaknesses
- CWE-178
Description
Improper Handling of Case Sensitivity vulnerability in Apache Tomcat's GCI servlet allows security constraint bypass of security constraints that apply to the pathInfo component of a URI mapped to the CGI servlet.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.6, from 10.1.0-M1 through 10.1.40, from 9.0.0.M1 through 9.0.104.
The following versions were EOL at the time the CVE was created but are
known to be affected: 8.5.0 though 8.5.100. Other, older, EOL versions
may also be affected.
Users are recommended to upgrade to version 11.0.7, 10.1.41 or 9.0.105, which fixes the issue.
Affected configurations
• apache tomcat (>= 9.0.0 < 9.0.105)
• apache tomcat (>= 10.1.0 < 10.1.41)
• apache tomcat (>= 11.0.0 < 11.0.7)
Related
Weakness · CWE (1)
- CWE-178 Improper Handling of Case Sensitivity weakness
References
- https://lists.apache.org/thread/xhqqk9w5q45srcdqhogdk04lhdscv30j Mailing List, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2025/05/29/4 Mailing List, Third Party Advisory
- https://lists.debian.org/debian-lts-announce/2025/07/msg00009.html lists.debian.org