CVEvulnerability
CVE-2025-46731
7.3 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2025-05-05
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 4.0 ([email protected])
- 7.3 HIGH — CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
- CVSS 3.1 ([email protected])
- 7.2 HIGH — CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-1336
Description
Craft is a content management system. Versions of Craft CMS on the 4.x branch prior to 4.14.13 and on the 5.x branch prior to 5.6.16 contains a potential remote code execution vulnerability via Twig SSTI. One must have administrator access and `ALLOW_ADMIN_CHANGES` must be enabled for this to work. Users should update to the patched versions 4.14.13 or 5.6.15 to mitigate the issue.
Affected configurations
• craftcms craft cms (>= 4.1.0 < 4.14.13)
• craftcms craft cms (>= 5.1.0 < 5.6.15)
• craftcms craft cms 4.0.0
• craftcms craft cms 5.0.0
Related
Weakness · CWE (1)
- CWE-1336 Improper Neutralization of Special Elements Used in a Template Engine weakness
References
- http://github.com/craftcms/cms/pull/17026 Patch
- https://craftcms.com/knowledge-base/securing-craft#set-allowAdminChanges-to-false-in-production Product
- https://github.com/craftcms/cms/security/advisories/GHSA-7c58-g782-9j38 Third Party Advisory
- https://github.com/craftcms/cms/security/advisories/GHSA-f3cw-hg6r-chfv Not Applicable