CVEvulnerability
CVE-2025-46817
8.8 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2025-10-03
- Last modified
- 2026-10-19
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.0 HIGH — CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
- CVSS 3.1 ([email protected])
- 8.8 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-190
Description
Redis is an open source, in-memory database that persists on disk. Versions 8.2.1 and below allow an authenticated user to use a specially crafted Lua script to cause an integer overflow and potentially lead to remote code execution The problem exists in all versions of Redis with Lua scripting. This issue is fixed in version 8.2.2.
Affected configurations
• redis redis (< 6.2.20)
• redis redis (>= 7.0 < 7.2.11)
• redis redis (>= 7.4.0 < 7.4.6)
• redis redis (>= 8.0.0 < 8.0.4)
• redis redis (>= 8.2.0 < 8.2.2)
Related
Weakness · CWE (1)
- CWE-190 Integer Overflow or Wraparound weakness