CVEvulnerability
CVE-2025-47276
7.5 HIGH
Official page ↗
- Status
- Deferred
- Published
- 2025-05-13
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- Weaknesses
- CWE-328
Description
Actualizer is a single shell script solution to allow developers and embedded engineers to create Debian operating systems (OS). Prior to version 1.2.0, Actualizer uses OpenSSL's "-passwd" function, which uses SHA512 instead of a more suitable password hasher like Yescript/Argon2i. All Actualizer users building a full Debian Operating System are affected. Users should upgrade to version 1.2.0 of Actualizer. Existing OS deployment requires manual password changes against the alpha and root accounts. The change will deploy's Debian's yescript overriding the older SHA512 hash created by OpenSSL. As a workaround, users need to reset both `root` and "Alpha" users' passwords.
Related
Weakness · CWE (1)
- CWE-328 Use of Weak Hash weakness
References
- https://cheatsheetseries.owasp.org/cheatsheets/Password_Storage_Cheat_Sheet.html cheatsheetseries.owasp.org
- https://github.com/ChewKeanHo/Actualizer/commit/32c9cc232c856f078f8269fba80ce7562bbff86b github.com
- https://github.com/ChewKeanHo/Actualizer/issues/1 github.com
- https://github.com/ChewKeanHo/Actualizer/releases/tag/v1.2.0 github.com
- https://github.com/ChewKeanHo/Actualizer/security/advisories/GHSA-v626-chv9-v9qr github.com
- https://github.com/openssl/openssl/issues/19340 github.com
- https://www.reddit.com/r/debian/comments/1kknzqi/actualizer_v110_upgraded www.reddit.com