CVEvulnerability

CVE-2025-47291

4.6 MEDIUM Published 2025-05-21 Modified 2026-06-17 Official page ↗
Status
Analyzed
Published
2025-05-21
Last modified
2026-06-17
Assigner
[email protected]
CVSS 4.0 ([email protected])
4.6 MEDIUM — CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:U/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
CVSS 3.1 ([email protected])
7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-266

Description

containerd is an open-source container runtime. A bug was found in the containerd's CRI implementation where containerd, starting in version 2.0.1 and prior to version 2.0.5, doesn't put usernamespaced containers under the Kubernetes' cgroup hierarchy, therefore some Kubernetes limits are not honored. This may cause a denial of service of the Kubernetes node. This bug has been fixed in containerd 2.0.5+ and 2.1.0+. Users should update to these versions to resolve the issue. As a workaround, disable usernamespaced pods in Kubernetes temporarily.

Affected configurations

• linuxfoundation containerd (>= 2.0.1 < 2.0.5)

Related

Weakness · CWE (1)

  • CWE-266 Incorrect Privilege Assignment weakness

References