CVEvulnerability

CVE-2025-47436

6.0 MEDIUM Published 2025-05-14 Modified 2026-06-17 Official page ↗
Status
Analyzed
Published
2025-05-14
Last modified
2026-06-17
Assigner
[email protected]
CVSS 4.0 ([email protected])
6.0 MEDIUM — CVSS:4.0/AV:L/AC:L/AT:P/PR:H/UI:A/VC:L/VI:H/VA:H/SC:L/SI:H/SA:H/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:N/AU:X/R:X/V:X/RE:M/U:Amber
CVSS 3.1 ([email protected])
9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-122

Description

Heap-based Buffer Overflow vulnerability in Apache ORC. A vulnerability has been identified in the ORC C++ LZO decompression logic, where specially crafted malformed ORC files can cause the decompressor to allocate a 250-byte buffer but then attempts to copy 295 bytes into it. It causes memory corruption. This issue affects Apache ORC C++ library: through 1.8.8, from 1.9.0 through 1.9.5, from 2.0.0 through 2.0.4, from 2.1.0 through 2.1.1. Users are recommended to upgrade to version 1.8.9, 1.9.6, 2.0.5, and 2.1.2, which fix the issue.

Affected configurations

• apache orc (< 1.8.9) • apache orc (>= 1.9.0 < 1.9.6) • apache orc (>= 2.0.0 < 2.0.5) • apache orc (>= 2.1.0 < 2.1.2)

Related

Weakness · CWE (1)

  • CWE-122 Heap-based Buffer Overflow weakness

References