CVEvulnerability
CVE-2025-47943
6.3 MEDIUM
Official page ↗
- Status
- Deferred
- Published
- 2025-06-24
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 6.3 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:L/A:N
- Weaknesses
- CWE-79
Description
Gogs is an open source self-hosted Git service. In application version 0.14.0+dev and prior, there is a stored cross-site scripting (XSS) vulnerability present in Gogs, which allows client-side Javascript code execution. The vulnerability is caused by the usage of a vulnerable and outdated component: pdfjs-1.4.20 under public/plugins/. This issue has been fixed for gogs.io/gogs in version 0.13.3.
Related
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://github.com/gogs/gogs/commit/110117b2e5e5baa4809c819bec701e929d2d8d40 github.com
- https://github.com/gogs/gogs/releases/tag/v0.13.3 github.com
- https://github.com/gogs/gogs/security/advisories/GHSA-xh32-cx6c-cp4v github.com
- https://www.hacktivesecurity.com/blog/2025/07/15/cve-2025-47943-stored-xss-in-gogs-via-pdf www.hacktivesecurity.com
- https://github.com/gogs/gogs/security/advisories/GHSA-xh32-cx6c-cp4v github.com