CVEvulnerability
CVE-2025-48068
2.3 LOW
Official page ↗
- Status
- Analyzed
- Published
- 2025-05-30
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 4.0 ([email protected])
- 2.3 LOW — CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:L/VI:N/VA:N/SC:L/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
- CVSS 3.1 ([email protected])
- 4.3 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N
- Weaknesses
- CWE-1385
Description
Next.js is a React framework for building full-stack web applications. In versions starting from 13.0 to before 14.2.30 and 15.0.0 to before 15.2.2, Next.js may have allowed limited source code exposure when the dev server was running with the App Router enabled. The vulnerability only affects local development environments and requires the user to visit a malicious webpage while npm run dev is active. This issue has been patched in versions 14.2.30 and 15.2.2.
Affected configurations
• vercel next.js (>= 13.0.0 < 14.2.30)
• vercel next.js (>= 15.0.0 < 15.2.2)
Related
Weakness · CWE (1)
- CWE-1385 Missing Origin Validation in WebSockets weakness
References
- https://github.com/vercel/next.js/security/advisories/GHSA-3h52-269p-cp9r Vendor Advisory
- https://vercel.com/changelog/cve-2025-48068 Vendor Advisory