CVEvulnerability
CVE-2025-48384
CISA Known Exploited Vulnerability
Git Link Following Vulnerability — Git Git
Git contains a link following vulnerability that stems from Git’s inconsistent handling of carriage return characters in configuration files.
- Added to KEV
- 2025-08-25
- Remediation due
- 2025-09-15
- Ransomware use
- Unknown
- Required action
- Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.
- Notes
- This vulnerability affects a common open-source component, third-party library, or a protocol used by different products. For more information, please see: https://github.com/git/git/security/advisories/GHSA-vwqx-4fm8-6qc9 ; https://access.redhat.com/errata/RHSA-2025:13933 ; https://alas.aws.amazon.com/AL2/ALAS2-2025-2941.html ; https://linux.oracle.com/errata/ELSA-2025-11534.html ; https://msrc.microsoft.com/update-guide/vulnerability/CVE-2025-48384 ; https://nvd.nist.gov/vuln/detail/CVE-2025-48384
- Status
- Analyzed
- Published
- 2025-07-08
- Last modified
- 2026-09-24
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 8.0 HIGH — CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H
- Weaknesses
- CWE-436, CWE-59
Description
Git is a fast, scalable, distributed revision control system with an unusually rich command set that provides both high-level operations and full access to internals. When reading a config value, Git strips any trailing carriage return and line feed (CRLF). When writing a config entry, values with a trailing CR are not quoted, causing the CR to be lost when the config is later read. When initializing a submodule, if the submodule path contains a trailing CR, the altered path is read resulting in the submodule being checked out to an incorrect location. If a symlink exists that points the altered path to the submodule hooks directory, and the submodule contains an executable post-checkout hook, the script may be unintentionally executed after checkout. This vulnerability is fixed in v2.43.7, v2.44.4, v2.45.4, v2.46.4, v2.47.3, v2.48.2, v2.49.1, and v2.50.1.
Affected configurations
• git-scm git (< 2.43.7)
• git-scm git (>= 2.44.0 < 2.44.4)
• git-scm git (>= 2.45.0 < 2.45.4)
• git-scm git (>= 2.46.0 < 2.46.4)
• git-scm git (>= 2.47.0 < 2.47.3)
• git-scm git (>= 2.48.0 < 2.48.2)
• git-scm git (>= 2.49.0 < 2.49.1)
• git-scm git (>= 2.50.0 < 2.50.1)
• debian debian linux 11.0
• apple xcode (< 26.0)
Related
References
- https://github.com/git/git/security/advisories/GHSA-vwqx-4fm8-6qc9 Vendor Advisory
- http://seclists.org/fulldisclosure/2025/Sep/60 Mailing List, Third Party Advisory
- http://www.openwall.com/lists/oss-security/2025/07/08/4 Mailing List
- https://lists.debian.org/debian-lts-announce/2025/10/msg00003.html Mailing List, Third Party Advisory
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2025-48384 US Government Resource