CVEvulnerability
CVE-2025-48924
5.3 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2025-07-11
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 5.3 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
- Weaknesses
- CWE-674
Description
Uncontrolled Recursion vulnerability in Apache Commons Lang.
This issue affects Apache Commons Lang: Starting with commons-lang:commons-lang 2.0 to 2.6, and, from org.apache.commons:commons-lang3 3.0 before 3.18.0.
The methods ClassUtils.getClass(...) can throw StackOverflowError on very long inputs. Because an Error is usually not handled by applications and libraries, a
StackOverflowError could cause an application to stop.
Users are recommended to upgrade to version 3.18.0, which fixes the issue.
Affected configurations
• apache commons lang (>= 2.0 < 2.6)
• apache commons lang (>= 3.0 < 3.18.0)
Related
Weakness · CWE (1)
- CWE-674 Uncontrolled Recursion weakness
References
- https://lists.apache.org/thread/bgv0lpswokgol11tloxnjfzdl7yrc1g1 Mailing List, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2025/07/11/1 www.openwall.com
- https://lists.debian.org/debian-lts-announce/2025/08/msg00000.html lists.debian.org
- https://lists.debian.org/debian-lts-announce/2025/08/msg00026.html lists.debian.org
- https://lists.debian.org/debian-lts-announce/2025/09/msg00032.html lists.debian.org
- https://lists.debian.org/debian-lts-announce/2025/09/msg00036.html lists.debian.org