CVEvulnerability
CVE-2025-48956
7.5 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2025-08-21
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-400
Description
vLLM is an inference and serving engine for large language models (LLMs). From 0.1.0 to before 0.10.1.1, a Denial of Service (DoS) vulnerability can be triggered by sending a single HTTP GET request with an extremely large header to an HTTP endpoint. This results in server memory exhaustion, potentially leading to a crash or unresponsiveness. The attack does not require authentication, making it exploitable by any remote user. This vulnerability is fixed in 0.10.1.1.
Affected configurations
• vllm vllm (>= 0.1.0 < 0.10.1.1)
Related
Weakness · CWE (1)
- CWE-400 Uncontrolled Resource Consumption weakness