CVEvulnerability
CVE-2025-49010
6.8 MEDIUM
Official page ↗
- Status
- Analyzed
- Published
- 2026-03-30
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 3.8 LOW — CVSS:3.1/AV:P/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:L
- CVSS 3.1 ([email protected])
- 6.8 MEDIUM — CVSS:3.1/AV:P/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-121
Description
OpenSC is an open source smart card tools and middleware. Prior to version 0.27.0, an attacker with physical access to the computer at the time user or administrator uses a token can cause a stack-buffer-overflow write in GET RESPONSE. The attack requires crafted USB device or smart card that would present the system with specially crafted responses to the APDUs. This issue has been patched in version 0.27.0.
Affected configurations
• opensc project opensc (< 0.27.0)
Related
Weakness · CWE (1)
- CWE-121 Stack-based Buffer Overflow weakness
References
- https://github.com/OpenSC/OpenSC/security/advisories/GHSA-q5cf-5wmx-9wh4 Vendor Advisory
- https://github.com/OpenSC/OpenSC/wiki/CVE-2025-49010 Vendor Advisory