CVEvulnerability
CVE-2025-49124
8.4 HIGH
Official page ↗
- Status
- Modified
- Published
- 2025-06-16
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 8.4 HIGH — CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-426
Description
Untrusted Search Path vulnerability in Apache Tomcat installer for Windows. During installation, the Tomcat installer for Windows used icacls.exe without specifying a full path.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.7, from 10.1.0 through 10.1.41, from 9.0.23 through 9.0.105.
The following versions were EOL at the time the CVE was created but are
known to be affected: 8.5.0 through 8.5.100 and 7.0.95 through 7.0.109. Other EOL versions may also be affected.
Users are recommended to upgrade to version 11.0.8, 10.1.42 or 9.0.106, which fix the issue.
Affected configurations
• apache tomcat (>= 9.0.23 < 9.0.106)
• apache tomcat (>= 10.1.0 < 10.1.42)
• apache tomcat (>= 11.0.0 < 11.0.8)
Related
Weakness · CWE (1)
- CWE-426 Untrusted Search Path weakness
References
- https://lists.apache.org/thread/lnow7tt2j6hb9kcpkggx32ht6o90vqzv Mailing List, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2025/06/16/3 Mailing List, Third Party Advisory