CVEvulnerability
CVE-2025-4919
8.8 HIGH
Official page ↗
- Status
- Modified
- Published
- 2025-05-17
- Last modified
- 2026-09-30
- Assigner
- [email protected]
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 8.8 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-125, CWE-787
Description
An attacker was able to perform an out-of-bounds read or write on a JavaScript object by confusing array index sizes. This vulnerability was fixed in Firefox 138.0.4, Firefox ESR 128.10.1, Firefox ESR 115.23.1, Thunderbird 128.10.2, and Thunderbird 138.0.2.
Affected configurations
• mozilla firefox (< 115.23.1)
• mozilla firefox (< 138.0.4)
• mozilla firefox (>= 116.0 < 128.10.1)
• mozilla thunderbird (< 128.10.2)
• mozilla thunderbird (>= 138.0 < 138.0.2)
Related
References
- https://bugzilla.mozilla.org/show_bug.cgi?id=1966614 Permissions Required
- https://www.mozilla.org/security/advisories/mfsa2025-36/ Vendor Advisory
- https://www.mozilla.org/security/advisories/mfsa2025-37/ Vendor Advisory
- https://www.mozilla.org/security/advisories/mfsa2025-38/ Vendor Advisory
- https://www.mozilla.org/security/advisories/mfsa2025-40/ Vendor Advisory
- https://www.mozilla.org/security/advisories/mfsa2025-41/ Vendor Advisory
- https://lists.debian.org/debian-lts-announce/2025/05/msg00024.html lists.debian.org
- https://lists.debian.org/debian-lts-announce/2025/05/msg00046.html lists.debian.org