CVEvulnerability

CVE-2025-49506

7.5 HIGH Published 2026-08-06 Modified 2026-09-29 Official page ↗
Status
Analyzed
Published
2026-08-06
Last modified
2026-09-29
Assigner
[email protected]
CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weaknesses
CWE-208

Description

APR-util versions 1.6.3 (and earlier) function apr_password_validate() was not constant-time with regards to hashes or passwords comparisons, potentially leaking their content via a side channel timing attack particularly on platforms without crypt() such as  Windows, BeOS, NetWare, or Android. Users are recommended to upgrade to version 1.6.4, which fixes this issue.

Affected configurations

• apache apr-util (>= 1.2.0 < 1.6.4)

Related

Weakness · CWE (1)

  • CWE-208 Observable Timing Discrepancy weakness

References