CVEvulnerability
CVE-2025-49763
7.5 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2025-06-19
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-400
Description
ESI plugin does not have the limit for maximum inclusion depth, and that allows excessive memory consumption if malicious instructions are inserted.
Users can use a new setting for the plugin (--max-inclusion-depth) to limit it.
This issue affects Apache Traffic Server: from 10.0.0 through 10.0.5, from 9.0.0 through 9.2.10.
Users are recommended to upgrade to version 9.2.11 or 10.0.6, which fixes the issue.
Affected configurations
• apache traffic server (>= 9.0.0 < 9.2.11)
• apache traffic server (>= 10.0.0 < 10.0.6)
Related
Weakness · CWE (1)
- CWE-400 Uncontrolled Resource Consumption weakness
References
- https://lists.apache.org/thread/15t32nxbypqg1m2smp640vjx89o6v5f8 Mailing List, Vendor Advisory