CVEvulnerability
CVE-2025-49812
7.4 HIGH
Official page ↗
- Status
- Modified
- Published
- 2025-07-10
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 7.4 HIGH — CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
- Weaknesses
- CWE-287
Description
In some mod_ssl configurations on Apache HTTP Server versions through to 2.4.63, an HTTP desynchronisation attack allows a man-in-the-middle attacker to hijack an HTTP session via a TLS upgrade.
Only configurations using "SSLEngine optional" to enable TLS upgrades are affected. Users are recommended to upgrade to version 2.4.64, which removes support for TLS upgrade.
Affected configurations
• apache http server (< 2.4.64)
Related
Weakness · CWE (1)
- CWE-287 Improper Authentication weakness
References
- https://httpd.apache.org/security/vulnerabilities_24.html Vendor Advisory
- http://www.openwall.com/lists/oss-security/2025/07/09/3 www.openwall.com
- http://www.openwall.com/lists/oss-security/2025/07/10/2 www.openwall.com
- http://www.openwall.com/lists/oss-security/2025/07/10/9 www.openwall.com
- https://lists.debian.org/debian-lts-announce/2025/08/msg00009.html lists.debian.org