CVEvulnerability
CVE-2025-50151
8.8 HIGH
Official page ↗
- Status
- Modified
- Published
- 2025-07-21
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 8.8 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-20
Description
File access paths in configuration files uploaded by users with administrator access are not validated.
This issue affects Apache Jena version up to 5.4.0.
Users are recommended to upgrade to version 5.5.0, which does not allow arbitrary configuration upload.
Affected configurations
• apache jena (< 5.5.0)
Related
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness
References
- https://lists.apache.org/thread/12gks5z40gh9bszn1xk8mz34gz586xss Issue Tracking, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2025/07/21/2 www.openwall.com