CVEvulnerability
CVE-2025-53003
8.2 HIGH
Official page ↗
- Status
- Deferred
- Published
- 2025-07-01
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 4.0 ([email protected])
- 8.2 HIGH — CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
- Weaknesses
- CWE-200, CWE-269, CWE-284
Description
The Janssen Project is an open-source identity and access management (IAM) platform. Prior to version 1.8.0, the Config API returns results without scope verification. This has a large internal surface attack area that exposes all sorts of information from the IDP including clients, users, scripts ..etc. This issue has been patched in version 1.8.0. A workaround for this vulnerability involves users forking and building the config api, patching it in their system following commit 92eea4d.
Related
References
- https://github.com/JanssenProject/jans/commit/92eea4d4637f1cae16ad2f07b2c16378ff3fc5f1 github.com
- https://github.com/JanssenProject/jans/issues/11575 github.com
- https://github.com/JanssenProject/jans/releases/tag/v1.8.0 github.com
- https://github.com/JanssenProject/jans/security/advisories/GHSA-373j-mhpf-84wg github.com
- https://github.com/JanssenProject/jans/issues/11575 github.com