CVEvulnerability
CVE-2025-53470
3.1 LOW
Official page ↗
- Status
- Analyzed
- Published
- 2026-01-10
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 3.1 LOW — CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
- Weaknesses
- CWE-125
Description
Out-of-bounds Read vulnerability in Apache NimBLE HCI H4 driver. Specially crafted HCI event could lead to invalid memory read in H4 driver.
This issue affects Apache NimBLE: through 1.8.
This issue requires a broken or bogus Bluetooth controller and thus severity is considered low.
Users are recommended to upgrade to version 1.9, which fixes the issue.
Affected configurations
• apache nimble (< 1.9.0)
Related
Weakness · CWE (1)
- CWE-125 Out-of-bounds Read weakness
References
- https://github.com/apache/mynewt-nimble/commit/b973df0c6cf7b30efbf8eb2cafdc1ee843464b76 Patch
- https://lists.apache.org/thread/32sm0944dyod4sdql77stgyw9xb2msc0 Mailing List, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2026/01/08/2 Mailing List, Third Party Advisory