CVEvulnerability
CVE-2025-53506
7.5 HIGH
Official page ↗
- Status
- Modified
- Published
- 2025-07-10
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-400
Description
Uncontrolled Resource Consumption vulnerability in Apache Tomcat if an HTTP/2 client did not acknowledge the initial settings frame that reduces the maximum permitted concurrent streams.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.8, from 10.1.0-M1 through 10.1.42, from 9.0.0.M1 through 9.0.106.
The following versions were EOL at the time the CVE was created but are
known to be affected: 8.5.0 through 8.5.100. Other EOL versions may also be affected.
Users are recommended to upgrade to version 11.0.9, 10.1.43 or 9.0.107, which fix the issue.
Affected configurations
• apache tomcat (>= 9.0.0 <= 9.0.106)
• apache tomcat (>= 10.1.0 <= 10.1.42)
• apache tomcat (>= 11.0.0 <= 11.0.8)
Related
Weakness · CWE (1)
- CWE-400 Uncontrolled Resource Consumption weakness
References
- https://lists.apache.org/thread/p09775q0rd185m6zz98krg0fp45j8kr0 Issue Tracking, Mailing List, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2025/07/10/13 www.openwall.com
- https://lists.debian.org/debian-lts-announce/2025/07/msg00009.html lists.debian.org