CVEvulnerability
CVE-2025-53628
6.3 MEDIUM
Official page ↗
- Status
- Analyzed
- Published
- 2025-07-10
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 4.0 ([email protected])
- 6.3 MEDIUM — CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
- CVSS 3.1 ([email protected])
- 8.8 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-444, CWE-770, CWE-835
Description
cpp-httplib is a C++11 single-file header-only cross platform HTTP/HTTPS library. Prior to 0.20.1, cpp-httplib does not have a limit for a unique line, permitting an attacker to explore this to allocate memory arbitrarily. This vulnerability is fixed in 0.20.1. NOTE: This vulnerability is related to CVE-2025-53629.
Affected configurations
• yhirose cpp-httplib (< 0.20.1)
Related
References
- https://github.com/yhirose/cpp-httplib/commit/7b752106ac42bd5b907793950d9125a0972c8e8e Patch
- https://github.com/yhirose/cpp-httplib/security/advisories/GHSA-j6p8-779x-p5pw Exploit, Vendor Advisory
- https://github.com/yhirose/cpp-httplib/security/advisories/GHSA-qjmq-h3cc-qv6w Not Applicable
- https://github.com/yhirose/cpp-httplib/security/advisories/GHSA-j6p8-779x-p5pw Exploit, Vendor Advisory