CVEvulnerability
CVE-2025-53689
8.8 HIGH
Official page ↗
- Status
- Modified
- Published
- 2025-07-14
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 8.8 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-611
Description
Blind XXE Vulnerabilities in jackrabbit-spi-commons and jackrabbit-core in Apache Jackrabbit < 2.23.2 due to usage of an unsecured document build to load privileges.
Users are recommended to upgrade to versions 2.20.17 (Java 8), 2.22.1 (Java 11) or 2.23.2 (Java 11, beta versions), which fix this issue. Earlier versions (up to 2.20.16) are not supported anymore, thus users should update to the respective supported version.
Affected configurations
• apache jackrabbit (>= 2.20.0 < 2.20.17)
• apache jackrabbit 2.22.0
• apache jackrabbit 2.23.0
• apache jackrabbit 2.23.1
Related
Weakness · CWE (1)
- CWE-611 Improper Restriction of XML External Entity Reference weakness
References
- https://lists.apache.org/thread/5pf9n76ny13pzzk765og2h3gxdxw7p24 Vendor Advisory
- http://www.openwall.com/lists/oss-security/2025/07/14/1 www.openwall.com