CVEvulnerability
CVE-2025-54378
8.3 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2025-07-26
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 8.3 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:H
- Weaknesses
- CWE-285, CWE-862
Description
HAX CMS allows you to manage your microsite universe with PHP or NodeJs backends. In versions 11.0.13 and below of haxcms-nodejs and versions 11.0.8 and below of haxcms-php, API endpoints do not perform authorization checks when interacting with a resource. Both the JS and PHP versions of the CMS do not verify that a user has permission to interact with a resource before performing a given operation. The API endpoints within the HAX CMS application check if a user is authenticated, but don't check for authorization before performing an operation. This is fixed in versions 11.0.14 of haxcms-nodejs and 11.0.9 of haxcms-php.
Affected configurations
• psu haxcms-nodejs (< 11.0.14)
• psu haxcms-php (< 11.0.9)
Related
References
- https://github.com/haxtheweb/haxcms-nodejs/commit/5826e9b7f3d8c7c7635411768b86b199fad36969 Patch
- https://github.com/haxtheweb/haxcms-php/commit/24d30222481ada037597c4d7c0a51a1ef7af6cfd Patch
- https://github.com/haxtheweb/issues/security/advisories/GHSA-9jr9-8ff3-m894 Exploit, Third Party Advisory
- https://github.com/haxtheweb/issues/security/advisories/GHSA-9jr9-8ff3-m894 Exploit, Third Party Advisory