CVEvulnerability

CVE-2025-54417

5.2 MEDIUM Published 2025-08-09 Modified 2026-06-17 Official page ↗
Status
Analyzed
Published
2025-08-09
Last modified
2026-06-17
Assigner
[email protected]
CVSS 4.0 ([email protected])
5.2 MEDIUM — CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
CVSS 3.1 ([email protected])
8.8 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-94

Description

Craft is a platform for creating digital experiences. Versions 4.13.8 through 4.16.2 and 5.5.8 through 5.8.3 contain a vulnerability that can bypass CVE-2025-23209: "Craft CMS has a potential RCE with a compromised security key". To exploit this vulnerability, the project must meet these requirements: have a compromised security key and create an arbitrary file in Craft's /storage/backups folder. With those criteria in place, attackers could create a specific, malicious request to the /updater/restore-db endpoint and execute CLI commands remotely. This issue is fixed in versions 4.16.3 and 5.8.4.

Affected configurations

• craftcms craft cms (>= 4.13.8 < 4.16.3) • craftcms craft cms (>= 5.5.8 < 5.8.4)

Related

Weakness · CWE (1)

  • CWE-94 Improper Control of Generation of Code weakness

References