CVEvulnerability
CVE-2025-54997
9.1 CRITICAL
Official page ↗
- Status
- Analyzed
- Published
- 2025-08-09
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 9.1 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H
- Weaknesses
- CWE-94
Description
OpenBao exists to provide a software solution to manage, store, and distribute sensitive data including secrets, certificates, and keys. In versions 2.3.1 and below, some OpenBao deployments intentionally limit privileged API operators from executing system code or making network connections. However, these operators can bypass both restrictions through the audit subsystem by manipulating log prefixes. This allows unauthorized code execution and network access that violates the intended security model. This issue is fixed in version 2.3.2. To workaround, users can block access to sys/audit/* endpoints using explicit deny policies, but root operators cannot be restricted this way.
Affected configurations
• openbao openbao (< 2.3.2)
Related
Weakness · CWE (1)
- CWE-94 Improper Control of Generation of Code weakness
References
- https://discuss.hashicorp.com/t/hcsec-2025-14-privileged-vault-operator-may-execute-code-on-the-underlying-host/76033 Not Applicable
- https://github.com/openbao/openbao/pull/1634 Issue Tracking
- https://github.com/openbao/openbao/releases/tag/v2.3.2 Release Notes
- https://github.com/openbao/openbao/security/advisories/GHSA-xp75-r577-cvhp Vendor Advisory