CVEvulnerability
CVE-2025-5687
7.8 HIGH
Official page ↗
- Status
- Modified
- Published
- 2025-06-11
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 7.8 HIGH — CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-269
Description
A vulnerability in Mozilla VPN on macOS allows privilege escalation from a normal user to root.
*This bug only affects Mozilla VPN on macOS. Other operating systems are unaffected.*. This vulnerability was fixed in Mozilla VPN 2.28.0 (macOS).
Affected configurations
• mozilla vpn (< 2.28.0)
Related
Weakness · CWE (1)
- CWE-269 Improper Privilege Management weakness
References
- https://bugzilla.mozilla.org/show_bug.cgi?id=1953736 Permissions Required
- https://www.mozilla.org/security/advisories/mfsa2025-48/ Vendor Advisory