CVEvulnerability
CVE-2025-57738
7.2 HIGH
Official page ↗
- Status
- Modified
- Published
- 2025-10-20
- Last modified
- 2026-10-08
- Assigner
- [email protected]
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 7.2 HIGH — CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-653
Description
Apache Syncope offers the ability to extend / customize the base behavior on every deployment by allowing to provide custom implementations of a few Java interfaces; such implementations can be provided either as Java or Groovy classes, with the latter being particularly attractive as the machinery is set for runtime reload.
Such a feature has been available for a while, but recently it was discovered that a malicious administrator can inject Groovy code that can be executed remotely by a running Apache Syncope Core instance.
Users are recommended to upgrade to version 3.0.14 / 4.0.2, which fix this issue by forcing the Groovy code to run in a sandbox.
Affected configurations
• apache syncope (>= 2.1.0 < 3.0.14)
• apache syncope (>= 4.0.0 < 4.0.2)
Related
Weakness · CWE (1)
- CWE-653 Improper Isolation or Compartmentalization weakness
References
- https://lists.apache.org/thread/x7cv6xv7z76y49grdr1hgj1pzw5zbby6 Mailing List, Release Notes
- http://www.openwall.com/lists/oss-security/2025/10/20/1 www.openwall.com